MINI Cooper Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey guys,

I have owned my '08 mini cooper S for 6 months now and have put approximately 8k mi on it. I took it in for an oil change last Thursday late afternoon at a chain oil place. Now thinking that was maybe a bad idea. The next day I had driven a total of 30 miles and my oil lamp light above my driving column started erratically going on and off. I pulled over immediately knowing any red light is a bad indicator. This however WAS NOT my engine light. Just the oil light. I had someone look at it where I had left it pulled over. There was no leak, oil levels looked good and and the oil looked clean. No knocking and performance of the vehicle seemed normal. I drove it home and the light did not come back on. 2 days later it came on again being very erratic and no change in performance. I then decided to arrange for a tow where I had it taken straight to my mechanic the next morning. He looked at everything however he did not have the proper machine to check the actual oil levels. He replaced the oil filter to ensure the spring was still intact. The chain oil place DID NOT use the proper OEM oil filter so we thought it was as simple as the oil filter even though he said the filter they used looked fine. He said everything else looked normal. I got my car today (a week after initial oil change). I still wasn't satisfied with everything so I went back to the original place I had gotten my oil changed to ask for a refund and on the way there the oil light went off AGAIN!!! So the oil filter was not the culprit. I then immediately took it to a European specialist and left it there with all of us scratching our heads. The car is running fine, the engine light has not come on once. And looking in my car while running they can see oil running through the engine. I need some ideas guys!!!! I find it very odd that not even 30 miles after I got my oil changed this happened as the light never came on prior too. I can't afford to keep "replacing things" to find out what's wrong. I LOVE this car as it has been amazing since I bought it. Might I add it only has 62k on it with proper maintenance. I use 89 octane which is what I was told to use and after checking, the oil place used the proper 5W-30 synthetic oil that my car needs.

PLEASE HELP!!!!!!!!!!!!!!!!!
 

·
Premium Member
Joined
·
3,829 Posts
The thing that controls your oil pressure light is the pressure switch on the engine, these are known to stick, play up or fail all together or maybe even if the wire connection to it isnt tight causing an intermittant circuit and making the light flicker.
If the mechanics have been working on the engine they might of disturbed the wire etc and now its in a position its tight again wont move so cured itself?
If the oil levels correct, the filter the right one, oil is the correct type and the engine is in general good condition this is probably what it is.
Check the oil pressure switch connections.
 
1 - 2 of 2 Posts
Top