MINI Cooper Forum banner

21 - 25 of 25 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #21
My thoughts exactly mate, car was running sweet before gasket, and nothing involved in gasket should change fueling. Odly enough the car now on occasion seems to suddenly get its performance back, still get the pinking though which wasn't there before, is it possible that the chain tensioner is maybe not holding oil pressure properly now, I guess, plugs look the same but judging the colour of them running lean. But timing and fueling can cause a lean run and nothing that effects fueling was changed on gasket change so again I am back suspecting timing. Tempted to just go to a 17% to reclaim the lost power.
 

·
Registered
Joined
·
3 Posts
It was just the head gasket that was changed so knock sensor wouldn't have been removed, and I'm sure it would throw a code. Don't see how I can loose about 20 hp and lbs unless the mechanic has done my ip birthday wishes tneb something wrong the only thing I can think of is timing. Thanks for reply
Only symptoms are engine pinging and every now and again the revs bog at idle then catch. I am thinking the mechanic has skipped a timing tooth. But looking for advice.
 

·
Registered
Joined
·
5,488 Posts
things that damage 02 sensors,,, oil burning ie most times valve stem seals,, this contaminates the 02 sensors ie replace with new is best option and reset the adaptations for them as well,, also head gasket failure where coolant and anti freeze kills them off, also the life span for a 02 sensor 60.000 miles is what Bosch say is about the life span and the sensors and cat should be treated as one system,, pull the upstream 02 sensor after a good hard run and see waht colour it is on oil burners they are bright white as semi blocked cat holds the heat in the precat area and the oil gets burnt off and leaves a white residue, i had a r53 that 100k needed head off and new valve stem seals put it back together and ran it and found as i expected when car was cold and not in closed loop running with 02 sensors and cat it went very well ie 1 to 2 to 3rd gear in dry traction light on wheel spin its also had a high lift cam and some other stuff done its going on rollers next week to be set up,, anyway when car got hot the car got slower holding back it was leaning out,, since decat and two new 02 sensors its as fast cold as hot some pics of head off and finished i also etc prime and coat super charger and intercooler so deals with heat as best as it can,,, notice the black build up from oil burning the cat was ruined from it as well
 

Attachments

·
Registered
Joined
·
5,488 Posts
Only symptoms are engine pinging and every now and again the revs bog at idle then catch. I am thinking the mechanic has skipped a timing tooth. But looking for advice.
trouble with the could of set timing out by a tooth its sort of one of those jobs that only a total plum could get it wrong just no real area for error its in your face the marks, 3 coloured chain links two to go two marks on crank pulley and one on cam shaft sprocket, the chain tensioner i have found after market ones are rubbish always fit genuine ones also they take a few miles to settle in, its common for the hard plastic pipes that plug in to inlet manifold under the throttle body to get cracked worth smoke testing the circuit, need to live data it see whats running where ie 02 sensors and see what drops when it does it maybe
 

·
Registered
Joined
·
25 Posts
Discussion Starter #25
Sorry its all good after seeing good compression across the board and finding out it was overfueling on all 4 cylinders I suspected the fuel pressure regulator which turned out to be correct. The performance is back to how it was before I suspect this is what caused the head gasket to blow.
 
21 - 25 of 25 Posts
Top