MINI Cooper Forum banner
1 - 5 of 5 Posts

·
MINI2 Regular
Joined
·
124 Posts
Discussion Starter · #1 ·
Hi all

I think I have a problem with the supercharger in that I can no longer hear the whine? It also feels like there is loss of power on acceleration. The engine sounds different on acceleration, a sort of gargly noise? Somebody did suggest that it may be some belt (??) slipping that drives the supercharger. At the moment, it feels like driving my old Cooper. Has anybody else had this problem? Any feedback would be appreciated.
 

·
Registered
Joined
·
145 Posts
Easy Enough to Check the belt

You can easily see if the belt is outright broken by opening the bonnet, looking to the left, and below the supercharger tubing. Its sort of behind the yellow oil-dip stick... There is a pulley behind there that should have a belt on it, if not, bingo!

Some other possibilities which have happened to other folks are:

1) Supercharger Belt Tensioner Fails (no belt tension=no air=no go)
2) Supercharger Pulley Fails (very unlikey)
3) Supercharger intake manifold has cracked (has happened a few times) same result as (1)

Could also be something entirely different, but these are my guesses.

I'd definitely get it in to a dealer as soon as you can...

Good Luck
RM
 

·
Registered
Joined
·
145 Posts
Here is a picture of the stuff

From another thread, here is a picture of the belt, and its tensioner, just so you know...

I believe part #3 is the supercharger pulley itself. The mechanism shown merely uses a big spring and another free-wheeling pulley to apply tension to the belt that drives the supercharger. If this mechanism were to fail, then its obvious how the belt would just go slack.
 

Attachments

·
MINI2 Regular
Joined
·
124 Posts
Discussion Starter · #4 ·
Thanks RallyMINI, I had a quick look and the belt is there. There is definitley something not right, there's like a scraping noise from the engine when the bonnet is open.

It's booked into the dealers on Tuesday.

thanks v much for the info :)
 

·
Registered
Joined
·
1,070 Posts
Peachiz said:
Thanks RallyMINI, I had a quick look and the belt is there. There is definitley something not right, there's like a scraping noise from the engine when the bonnet is open.

It's booked into the dealers on Tuesday.

thanks v much for the info :)
Don't forget to keep us updated to what the problem is/was ;)
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top