MINI Cooper Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
my r53 is having issues with the transmission, i changed all the solenoids and still have issues with up shift to 4th and above. I have a very good scanner and it is not picking up the dme and tcm. I have gone through looking for shorts and rubs I can not find anything. All I see on line is people posting but no repairs. In the fuse box engine side there is a plug that is in the box. I have power on everything but pin 10. Its a red wire and I cannot find it in the schematics. I understand that there are three things that connect to the bussi have checked all three by disconnecting one at a time and.nothing changes. I have check Grounds and fund nothing. Does anyone have a clue all fuses good ,no bad wires in connections .I'm no dummy I have been building cars all my life but not on mini.this is my daughter's car and its been on my lift for 2 weeks and I need it off. The last thing that recorded was S1 and all the solenoids are new and it goes right into limp mode after warming up . I can't do streaming because I. An connect.
Please any information is useful.
An early thank you😉
Electronic component Data storage device Gadget Office equipment Computer hardware
 

·
Registered
Joined
·
10,217 Posts
need to scan the system its only way and being a auto as well will need to be able to reset the gearbox learnings adaptions ,, snap on diagnostics tool with euro cars update should do it it should also allow you to run live data to gearbox ecu and body control module as the bcm is linked ie its in the path of the control ie the gearshift will send a signal to bcm for what gear its in etc, and to the gearbox ecu that controls the solonoids,, so will need to be able to see all ecu's and run live data while picking at wiring and sensors etc , not easy job to be honest, think i have failed as many times as found faults with auto system system,
 
1 - 2 of 2 Posts
Top