MINI Cooper Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
As it says,

I'm looking for a blown engine to rebuild. I dont want a good running engine as it has to be cheap.

What you guys and gals got???

PM me with spec and price and also include location.
UK only as I would collect myself.
 

·
Registered
Joined
·
8,291 Posts
cheaper to find a Peugeot or Citroen one
 

·
Registered
Joined
·
83 Posts
Discussion Starter #3
Hi mate.
What engine codes do I need to look out for to rebuild?
I'm thinking of doing my own work on the head and go down the blue printing and even lighten balance the crank.
Do then engines have the same oil injectors and same forged crank and rods?
 

·
Registered
Joined
·
8,291 Posts
they are not forged from factory, there is a big difference between n14 and n18 engines,
Peugeot ep6t ie 207 gti or 308 gt same engines, the later cars have n18 engines so after 2012 ish on psa will be n18 same as, 207gti 2006-2012 is n14 same as,,
cranks are strong good for over 350bhp, the rods wont like anything above 250bhp tend to bend,, mahl brand do good forge kits pistons and rods and arl bolts etc, the later engine have a ecu controlled oil pump where pre n18 dont, if rebuilding one deffo fit new oil pump,, on line neo brothers are fair on price and very good gear, FAI do good crank bearings and good timing chain kits,, i would only fit genuine vanos sprocket and genuine tensioner ie the latest spec long one, the heads can only be skimmed once, i always fit the over size head gasket anyway ie 2 notch,, i also use wellseal on head gaskets these days as have good results using it,, helps reduce head lift when throwing power at them its seems,
 

·
Registered
Joined
·
83 Posts
Discussion Starter #6
Sorry I want a w11 motor for my r53.
I'm not a fan of the n14 and love the supercharger.
 

·
Registered
Joined
·
8,291 Posts
i know a guy who has two for sale in plymouth
 

·
Registered
Joined
·
8,291 Posts
its one of those things ie and i have done it before bought a rebuilder engine to find head was cracked or cracked liner, sometimes better to find a running engine and refresh it in long run, i'll ask him tomorrow, he travels up and down country as well so might be able to get it to you or close , and he is a honest guy and knows what is good and bad in first place of that makes sense
 

·
Registered
Joined
·
160 Posts
Tons of clapped out mini Cooper s on Facebook marketplace, obviously you have to read in between the lines but also some people are desperate to just get rid of them and you can get them for peanuts
 

·
Registered
Joined
·
83 Posts
Discussion Starter #13
@mike1967 I've got another problem and used the diagnostic tool you said to buy. It's a little complicated at the moment but I'll get used to it.
The problem is ABS light on and ASC also lit. Fault code gives front left speed sensor so I've changed it for both a BMW one and an After market one just incase one was faulty and still the same. Plug checked and continuity checked to plug on ABS pump.
Is there anything else I should check before I go and change the pump?
Turn key off and back on and lights god out till you set off and then comes back on. Deffo something to do with that wheel.
Could it be broken solder joint in pump or is it a pump fault?
Any help would get good.
Cheers mate.
 

·
Registered
Joined
·
8,291 Posts
might be the ring in the hub its self ,, abs sensor works hall effect so when turn wheel should generate its own voltage ,
common for gen 1 cars abs pump ecu to go faulty
 

·
Registered
Joined
·
83 Posts
Discussion Starter #15
might be the ring in the hub its self ,, abs sensor works hall effect so when turn wheel should generate its own voltage ,
common for gen 1 cars abs pump ecu to go faulty
So can I measure the voltage from the ring so how?
I take it there is a south pole set in the ring for the sensor to pick up on? It's not got teeth like others.
 

·
Registered
Joined
·
8,291 Posts
below link
So can I measure the voltage from the ring so how?
I take it there is a south pole set in the ring for the sensor to pick up on? It's not got teeth like others.
below ink for replacement ring sort of part of the hub, common rust will damage them, when ignition is switched off and back on the bas ecu resets zero to each sensor for ref points,, can use a multimeter on microvolts and use a plug breakout to the sensor at the wheel sensor see what is produces and working when spin wheel by hand, ,,do same on each wheel spin at same speed i fit a drill with a socket to centre hob nut and spin it while reading them as then will get same speed on all to match it up ,, ie then all 4 should read same volts, any that dont are suspect,, i then do same by connect to signal wires at ecu end this should check the wiring out at same time,, or could buy a £2000 snap on diagnostics tool and that will display all these figures without the making stuff up if that makes sense
 

·
Registered
Joined
·
83 Posts
Discussion Starter #17
below link

below ink for replacement ring sort of part of the hub, common rust will damage them, when ignition is switched off and back on the bas ecu resets zero to each sensor for ref points,, can use a multimeter on microvolts and use a plug breakout to the sensor at the wheel sensor see what is produces and working when spin wheel by hand, ,,do same on each wheel spin at same speed i fit a drill with a socket to centre hob nut and spin it while reading them as then will get same speed on all to match it up ,, ie then all 4 should read same volts, any that dont are suspect,, i then do same by connect to signal wires at ecu end this should check the wiring out at same time,, or could buy a £2000 snap on diagnostics tool and that will display all these figures without the making stuff up if that makes sense
Ok I got some magnetic paper and when I put it on the bearing there was a few segments missing so just got a new front hub. Fitting it tomorrow.
I have a snapon diagnostic, ethos, and run live data and there is a reading from n/s/f but no change when its turning. I believe its seeing the wheel but not seeing movement.
Will let you know what happens after I fit the front bearing.
 

·
Registered
Joined
·
8,291 Posts
@mike1967 I fitted the new bearing and all is good.
Thanks for your input mate. 👍
happy days nice when things go right, i've had a problem child a 7 seat citreon that i finally got to run right one of those jobs fix one bit to find another bit then buy new parts that are faulty just to confuse things,,, but finally today got it sounding perfect and all live data looks like new engine,, hmmm after a full rebuild and new cat new 02 sensors and thermo housing and water pump radiator,,, teach me for buying it on the phone and trust a car sales man who said it had not lost coolant etc, reality was it was so badly cooked it dropped the valve seats out the heat, so another head and new rings and crack bearings to find the head i used was cracked so off again found another head from a car that had driven through a flood and bent all the rods,, and finally all runs well after all valves out and new guides and stem seals and lap all valve seats in etc, all that inbetween 12 other engine rebuilds and other stuff last year so ended up being fitted in around stuff, cars just seem to throw side balls all the time,
 

·
Registered
Joined
·
83 Posts
Discussion Starter #20
@mike1967 wow you did have a bad egg there mate. Glad you managed to get it running.
Them kerb balls are crap and it's hard to keep going and so easy to just scrap the car. I'm glad you kept going, not many people would.
 
1 - 20 of 20 Posts
Top